This project is read-only.

Image accepted but figure block isn't recognized

Oct 13, 2016 at 5:10 PM
I have a situation where Modoko accepts the graphical content (the image) of a figure, inserting it the formatted HTML preview, but doesn't but doesn't seem to recognize the figure block itself.
Not shown in Fig. [#fig-rofa] is the behavior at even higher levels, when the pulse amplitude delivers sufficient charge to overcome the large shunting of the potassium conductance.  At the higher current levels, action potentials *are* produced later in the pulse train. 


~ Figure { #NsOfTpic_AI; caption:"My figure"}
  ![nsoftpic_ai]
~


## Matching 
Any idea what could cause this behavior? I am still fairly new to Madoko, so your help would be greatly appreciated!

Warm regards,
FS

P.S. I wanted to attach a screenshot stored on my local drive, but couldn't figure out how to do this on Codeplex. Might you tell me how to do that?
Oct 13, 2016 at 6:00 PM
Hi, FS,

Your sample works fine when I try it? Do you mean the [#fig-rofa] is not working? That is because the id of your figure is #NsOfTpic_AI?

Perhaps you mean that the FIgure is not recognized at all and displayed as text? In that case, you may have the ~ nested inside some other block -- or a previous block is not ended correctly. You can try to write ~ Begin Figure and ~ End Figure instead to see if that fixes things.

Let me know how it goes,
-- Daan
Oct 14, 2016 at 4:00 AM
you may have the ~ nested inside some other block
This was essentially correct as I had a stray ~ way up in some earlier paragraph.

Thanks for the help, Daan.

-FS